Don't forget to check your spam folder if you don't get an activation email after joining!!

OpenXsensor

Discussion about Tx, Rx, Servo's, Batteries, Chargers, and all the other things we like to talk about..
Moderator: VinceC
User avatar
Peter Balcombe
Posts: 1142
Joined: 18 Mar 2015, 10:13
Location: Clevedon, North Somerset, U.K.

OpenXsensor

Post by Peter Balcombe »

Has anyone else tried using the openXSensor library for Arduino type hardware to make bespoke telemetry sensors?
The openXsensor library is compatible with FrSky, Graupner & Jeti telemetry systems and can be used to make your own telemetry sensors units to monitor any combination of the following with the a small Arduino Pro Mini board and standard sensor hardware items:

Voltage (e.g. LiPo/individuals cells etc. via simple resistor dividers)
Current (e.g. Flight battery via Hall or very low resistance based sensors)
Altimeter/Variometer (via barometric pressure & temperature sensor)
GPS data (using standard commercial GPS antenna/module)
Airspeed (via pitot head & differential pressure sensor as used on say FrSky commercial units)
Motion (via 3 axis accelerometer/gyro and/or magnetometer)
Temperature (via thermistors)
RPM (via pulse generating sensor)
Flow (e.g. fuel via an impeller type pulse generating sensor)

Chris Bott did a couple of articles in RCM&E a few months ago & I have now successfully produced two different units.
One can measure 4S LiPo cell voltages, current up to 120A, plus Altimeter/Vario - the black unit.
The second does GPS & Altimeter/Vario - shown before heatshrink added. GPS is the square block at opposite end to the barometric sensor, both being above the small processor board.
Overall size of each unit is about 2” x 1” x 0.5” in old money.

The units are fairly easy to produce if you are handy with a small soldering iron & have a PC to run the Arduino software in order to compile & upload the required code to the processor board.
Attachments
LiPo, Amps, Alt/Vario
LiPo, Amps, Alt/Vario
GPS & Alt/Vario
GPS & Alt/Vario

Weds
Posts: 11
Joined: 19 Mar 2015, 21:25
Location: Kent

Re: OpenXsensor

Post by Weds »

Yes, I've made quite a few GPS/Varios for my Gliders, also a few current/voltage modules, Chris put a post on the OpenTx forum before it was put on RCM&E and I started making them from there.

Arduinos are clever little things, took me a while to get my head around the programing side, changing parameters to suit the module etc.

I started making my own because my Frsky GPS module took forever to lock onto a signal even when it open air. And I found their varios would lock up when in flight. And they are so cheap to produce.

I also tried to make a 3 axis accelerometer without any success, I could never get the configuration right.

User avatar
Peter Balcombe
Posts: 1142
Joined: 18 Mar 2015, 10:13
Location: Clevedon, North Somerset, U.K.

Re: OpenXsensor

Post by Peter Balcombe »

Hi Weds,
Interesting that you had a problem with a 3 axis accelerometer.
Did you use a GY86 IMU unit?
It looks as if you need to assign the X_ACC, Y_ACC & Z_ACC to the TEST1-3 parameters, then fill the TEST parameters with LINEAR_ACC values. Were you already doing that?
If using a GY86 then you should note that it has an MS6311, so you may also need to disable this if you have another altimeter source operational.
Peter

Weds
Posts: 11
Joined: 19 Mar 2015, 21:25
Location: Kent

Re: OpenXsensor

Post by Weds »

Hi Peter

The boards are GY-521, just looking on Ebay I see the GY-86 boards are around £20 ! Not sure what the difference is, my ones were only a couple of quid.. I remember having to put the board in 3 different axis and enter the figures in the config file but I could never get sensible results coming back to my Tx..

User avatar
Peter Balcombe
Posts: 1142
Joined: 18 Mar 2015, 10:13
Location: Clevedon, North Somerset, U.K.

Re: OpenXsensor

Post by Peter Balcombe »

Weds,
I am awaiting a GY-86 from Banggood (£14).
The GY-86 also has a 3 axis magnetometer & is one of those specifically identified in the config files.
Yes, there is a calibration procedure which need offsets etc. fed back into config file.
Hopefully, mine will arrive by the end of Jan & can give it a whirl then to see if I have any problems.

Weds
Posts: 11
Joined: 19 Mar 2015, 21:25
Location: Kent

Re: OpenXsensor

Post by Weds »

I've ordered one from Banggood too, see if I can make more sense with one of these.

User avatar
Peter Balcombe
Posts: 1142
Joined: 18 Mar 2015, 10:13
Location: Clevedon, North Somerset, U.K.

Re: OpenXsensor

Post by Peter Balcombe »

Weds,
Just found (and now found a way around) a problem with the IDE failing to compile a sensor sketch which had the 1st Vario set to NO_BARO option to cater for use with an Rx equipped with built-in Altimeter/Vario.
(I was trying to use different sets of uniquely named config files for different sensor sketches).

Anyway, be warned that the IDE compiler doesn’t appear to like using other than the default config filenames with the 1st Vario set to NO_BARO & some other options.
(The OpenXsensor developers know of my issue, so maybe they will find a way to make it easier to link different config files to each senso sketch).

Weds
Posts: 11
Joined: 19 Mar 2015, 21:25
Location: Kent

Re: OpenXsensor

Post by Weds »

Thanks for the info Peter.

User avatar
Peter Balcombe
Posts: 1142
Joined: 18 Mar 2015, 10:13
Location: Clevedon, North Somerset, U.K.

Re: OpenXsensor

Post by Peter Balcombe »

Weds,
Another solution to the OpenXsensor NO_BARO issue is to use a different project file structure.
I was using the standard? system of having sketches & a libraries folder at the same directory level in an Arduino Projects folder.
A better setup for OpenXsensor is to have everything In an OpenXsensor folder, with individual clones of OpenXsensor for each project. Each project then has its own config files which have been tweaked to suit that project. The standard sketch can be run from within the project folder.
Uses 1.2MB disk space for each project, but works every time & no confusion with config setups ;)

By the way, I saw a couple of threads on the OpenXsensor forum which covered setting up MCU projects, including getting the correct g values.

FrankS
Posts: 304
Joined: 18 Mar 2015, 14:29
Location: Gloucestershire

Re: OpenXsensor

Post by FrankS »

I've made a few Varios to use with Multiplex M Link systems, work well, but my soldering skills aren't the best :oops: I bought a few of the boards to make some ammeter/varios but never got round to it. Must admit I find the OpenXsensor page a bit of a pain to navigate around.

Post Reply